Short answer: This is a very sad error. Certain columns will randomly fail to pull in from a saved search. This is an error on the InfusionSoft API that has been broken in InfusionSoft since 2014.

Long story short, there is no fix until InfusionSoft fixes their API. 😕 You can get around it by using a different column or trying to create a new saved search with the same parameters.

Sometimes when using saved searches from InfusionSoft, certain columns will cause the report data to fail with this error.

faultCode4faultString[DatabaseError]Column not found in resultset:_Return 

Or it might look like this: <?xml version="1.0" encoding="UTF-8"?><methodResponse><fault><value><struct><member><name>faultCode</name><value><i4>4</i4></value></member><member><name>faultString</name><value>[DatabaseError]Column not found in resultset:_Return</value></member></struct></value></fault></methodResponse>

The most important parts of this error are the #4, and the result: [DatabaseError]Column not found in resultset

This is a super frustrating bug because there is nothing that Grow can do about it at the moment. InfusionSoft has bugs in their API, where certain columns will cause data to not return, and fail with this error.

Here is a post in the InfusionSoft development forum from 2014 where the suggested solution is to not use the specific column that caused the error. :( Not a great solution. http://community.infusionsoft.com/showthread.php/17811-SavedSearch-API-Error-4-Column-not-found-in-resultset-ProductName

And here is a forum post from 2015 where it is suggested that you can only modify each saved search once. :( http://community.infusionsoft.com/showthread.php/19936-Missing-Columns-on-getSavedSearchResultsAllFields?highlight=Column

There are a few things you can try. You can get around it by using a different column, or pulling in a second report and joining using SQLite. Or you can try creating a new saved search with the same parameters and try that new Id.

We recognize that this is incredibly frustrating. We would encourage you to reach out to InfusionSoft support about this.

You can post in their forum here - InfusionSoft Forum

If you have any questions, or need more help, please email support@grow.com or chat in on the site.

Did this answer your question?